summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/lighttpd/lighttpd.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 3ac1f07ad..e6f913cbc 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -44,11 +44,10 @@ else
LIGHTTPD_CONF_OPT += --without-pcre
endif
-$(eval $(call AUTOTARGETS,package,lighttpd))
-
-$(LIGHTTPD_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define LIGHTTPD_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/lighttpd
rm -f $(TARGET_DIR)/usr/sbin/lighttpd-angel
rm -rf $(TARGET_DIR)/usr/lib/lighttpd
- rm -f $(LIGHTTPD_TARGET_INSTALL_TARGET) $(LIGHTTPD_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,lighttpd))