summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES4
-rw-r--r--package/lsof/lsof.mk9
2 files changed, 8 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index 289a6b263..9fbfe9f58 100644
--- a/CHANGES
+++ b/CHANGES
@@ -9,6 +9,10 @@
Updated/fixed packages: busybox, freetype, mplayer, opencv,
rsyslog, xapp_xf86dga
+ Issues resolved (http://bugs.uclibc.org):
+
+ #4369: Fix permissions on untared lsof archive
+
2011.11-rc2, Released November 18th, 2011:
Fixes all over the tree and new features.
diff --git a/package/lsof/lsof.mk b/package/lsof/lsof.mk
index ff76f92c6..c07fb2da3 100644
--- a/package/lsof/lsof.mk
+++ b/package/lsof/lsof.mk
@@ -33,13 +33,12 @@ endef
endif
# The .tar.bz2 contains another .tar, which contains the source code.
-define LSOF_EXTRACT_TAR
- $(TAR) $(TAR_STRIP_COMPONENTS)=1 -xf $(@D)/lsof_$(LSOF_VERSION)_src.tar -C $(@D)
- rm -f $(@D)/lsof_$(LSOF_VERSION)_src.tar
+define LSOF_EXTRACT_CMDS
+ $(INFLATE.bz2) $(DL_DIR)/$(LSOF_SOURCE) | \
+ $(TAR) -O $(TAR_OPTIONS) - lsof_$(LSOF_VERSION)/lsof_$(LSOF_VERSION)_src.tar | \
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(LSOF_DIR) $(TAR_OPTIONS) -
endef
-LSOF_POST_EXTRACT_HOOKS += LSOF_EXTRACT_TAR
-
define LSOF_CONFIGURE_CMDS
(cd $(@D) ; \
echo n | $(TARGET_CONFIGURE_OPTS) DEBUG="$(TARGET_CFLAGS) $(BR2_LSOF_CFLAGS)" \