summaryrefslogtreecommitdiff
path: root/fs/squashfs/squashfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'fs/squashfs/squashfs.mk')
-rw-r--r--fs/squashfs/squashfs.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 91a7534de..a680dae0f 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -11,11 +11,15 @@ ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
ROOTFS_SQUASHFS_ARGS += -comp lzo
else
ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZMA),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzma
+else
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_XZ),y)
ROOTFS_SQUASHFS_ARGS += -comp xz
else
ROOTFS_SQUASHFS_ARGS += -comp gzip
endif
endif
+endif
else
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3