summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/squashfs/Config.in3
-rw-r--r--fs/squashfs/squashfs.mk4
2 files changed, 7 insertions, 0 deletions
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
index 85416becb..f13410a1c 100644
--- a/fs/squashfs/Config.in
+++ b/fs/squashfs/Config.in
@@ -37,5 +37,8 @@ config BR2_TARGET_ROOTFS_SQUASHFS4_LZMA
config BR2_TARGET_ROOTFS_SQUASHFS4_LZO
bool "lzo"
+config BR2_TARGET_ROOTFS_SQUASHFS4_XZ
+ bool "xz"
+
endchoice
endif
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 91a7534de..a680dae0f 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -11,11 +11,15 @@ ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
ROOTFS_SQUASHFS_ARGS += -comp lzo
else
ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZMA),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzma
+else
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_XZ),y)
ROOTFS_SQUASHFS_ARGS += -comp xz
else
ROOTFS_SQUASHFS_ARGS += -comp gzip
endif
endif
+endif
else
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3