summaryrefslogtreecommitdiff
path: root/make/uclibc_toolchain.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/uclibc_toolchain.mk')
-rw-r--r--make/uclibc_toolchain.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 0b2c597be..ee65c7ff4 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -442,7 +442,9 @@ $(BUILD_DIR)/.shuffled: $(GCC_BUILD_DIR2)/.fixedup
touch $(BUILD_DIR)/.shuffled
$(BUILD_DIR)/.stripped: $(BUILD_DIR)/.shuffled
- -$(STRIP) --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+ # Strip the host binaries
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+ # Strip the target shared libs
-$(STRIP) --strip-unneeded -R .note -R .comment $(STAGING_DIR)/lib/*.so*;
touch $(BUILD_DIR)/.stripped