summaryrefslogtreecommitdiff
path: root/make/uclibc_toolchain.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-22 11:11:35 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-22 11:11:35 +0000
commit5867ff49d76c55f5be2d7def2071ad99c98f5012 (patch)
tree46d36dc9957c9f6d1232737289306ef9c44cbece /make/uclibc_toolchain.mk
parent235a05b0c038be3cdd4c4d248b4c9a81694cf188 (diff)
use the correct strip tool for host and target binaries
Diffstat (limited to 'make/uclibc_toolchain.mk')
-rw-r--r--make/uclibc_toolchain.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 0b2c597be..ee65c7ff4 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -442,7 +442,9 @@ $(BUILD_DIR)/.shuffled: $(GCC_BUILD_DIR2)/.fixedup
touch $(BUILD_DIR)/.shuffled
$(BUILD_DIR)/.stripped: $(BUILD_DIR)/.shuffled
- -$(STRIP) --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+ # Strip the host binaries
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+ # Strip the target shared libs
-$(STRIP) --strip-unneeded -R .note -R .comment $(STAGING_DIR)/lib/*.so*;
touch $(BUILD_DIR)/.stripped