summaryrefslogtreecommitdiff
path: root/package/x11r7/openchrome/openchrome-r355-cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/x11r7/openchrome/openchrome-r355-cross-compile.patch')
-rw-r--r--package/x11r7/openchrome/openchrome-r355-cross-compile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/x11r7/openchrome/openchrome-r355-cross-compile.patch b/package/x11r7/openchrome/openchrome-r355-cross-compile.patch
new file mode 100644
index 000000000..de12e5493
--- /dev/null
+++ b/package/x11r7/openchrome/openchrome-r355-cross-compile.patch
@@ -0,0 +1,35 @@
+--- openchrome-r355/configure.ac.orig 2007-06-10 15:07:43.000000000 +0200
++++ openchrome-r355/configure.ac 2007-06-10 15:11:16.000000000 +0200
+@@ -69,12 +69,18 @@
+ AC_HEADER_STDC
+
+ if test "$DRI" != no; then
++ if test "$cross_compiling" = "no" ; then
+ AC_CHECK_FILE([${sdkdir}/dri.h],
+ [have_dri_h="yes"], [have_dri_h="no"])
+ AC_CHECK_FILE([${sdkdir}/sarea.h],
+ [have_sarea_h="yes"], [have_sarea_h="no"])
+ AC_CHECK_FILE([${sdkdir}/dristruct.h],
+ [have_dristruct_h="yes"], [have_dristruct_h="no"])
++ else
++ have_dri_h="yes"
++ have_sarea_h="yes"
++ have_dristruct_h="yes"
++ fi
+ fi
+
+ AC_MSG_CHECKING([whether to include DRI support])
+@@ -113,8 +119,12 @@
+
+ AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
+
+-AC_CHECK_FILE([${sdkdir}/xf86Module.h],
++if test "$cross_compiling" = "no" ; then
++ AC_CHECK_FILE([${sdkdir}/xf86Module.h],
+ [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
++else
++ have_xf86Module_h="yes"
++fi
+
+ # Check the ABI_VIDEODRV_VERSION
+ SAVE_CPPFLAGS="$CPPFLAGS"