summaryrefslogtreecommitdiff
path: root/package/x11r7/openchrome
diff options
context:
space:
mode:
Diffstat (limited to 'package/x11r7/openchrome')
-rw-r--r--package/x11r7/openchrome/Config.in16
-rw-r--r--package/x11r7/openchrome/openchrome-r355-cross-compile.patch35
-rw-r--r--package/x11r7/openchrome/openchrome.mk15
3 files changed, 66 insertions, 0 deletions
diff --git a/package/x11r7/openchrome/Config.in b/package/x11r7/openchrome/Config.in
new file mode 100644
index 000000000..1f90a7644
--- /dev/null
+++ b/package/x11r7/openchrome/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_OPENCHROME
+ bool "openchrome"
+ default n
+ select BR2_PACKAGE_XSERVER_XORG_SERVER
+ select BR2_PACKAGE_LIBDRM
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXVMC
+ select BR2_PACKAGE_XPROTO_GLPROTO
+ select BR2_PACKAGE_XPROTO_RANDRPROTO
+ select BR2_PACKAGE_XPROTO_RENDERPROTO
+ select BR2_PACKAGE_XPROTO_XEXTPROTO
+ select BR2_PACKAGE_XPROTO_XF86DRIPROTO
+ select BR2_PACKAGE_XPROTO_XPROTO
+ help
+ Openchrome, A free and Open Source video driver for the VIA/S3G
+ UniChrome and UniChrome Pro graphics chipsets.
diff --git a/package/x11r7/openchrome/openchrome-r355-cross-compile.patch b/package/x11r7/openchrome/openchrome-r355-cross-compile.patch
new file mode 100644
index 000000000..de12e5493
--- /dev/null
+++ b/package/x11r7/openchrome/openchrome-r355-cross-compile.patch
@@ -0,0 +1,35 @@
+--- openchrome-r355/configure.ac.orig 2007-06-10 15:07:43.000000000 +0200
++++ openchrome-r355/configure.ac 2007-06-10 15:11:16.000000000 +0200
+@@ -69,12 +69,18 @@
+ AC_HEADER_STDC
+
+ if test "$DRI" != no; then
++ if test "$cross_compiling" = "no" ; then
+ AC_CHECK_FILE([${sdkdir}/dri.h],
+ [have_dri_h="yes"], [have_dri_h="no"])
+ AC_CHECK_FILE([${sdkdir}/sarea.h],
+ [have_sarea_h="yes"], [have_sarea_h="no"])
+ AC_CHECK_FILE([${sdkdir}/dristruct.h],
+ [have_dristruct_h="yes"], [have_dristruct_h="no"])
++ else
++ have_dri_h="yes"
++ have_sarea_h="yes"
++ have_dristruct_h="yes"
++ fi
+ fi
+
+ AC_MSG_CHECKING([whether to include DRI support])
+@@ -113,8 +119,12 @@
+
+ AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
+
+-AC_CHECK_FILE([${sdkdir}/xf86Module.h],
++if test "$cross_compiling" = "no" ; then
++ AC_CHECK_FILE([${sdkdir}/xf86Module.h],
+ [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
++else
++ have_xf86Module_h="yes"
++fi
+
+ # Check the ABI_VIDEODRV_VERSION
+ SAVE_CPPFLAGS="$CPPFLAGS"
diff --git a/package/x11r7/openchrome/openchrome.mk b/package/x11r7/openchrome/openchrome.mk
new file mode 100644
index 000000000..713b68791
--- /dev/null
+++ b/package/x11r7/openchrome/openchrome.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# openchrome
+#
+#############################################################
+OPENCHROME_VERSION = r355
+OPENCHROME_SOURCE = openchrome-$(OPENCHROME_VERSION).tar.bz2
+OPENCHROME_SITE = http://bazaar.mezis.net/
+
+OPENCHROME_DEPENDANCIES = xserver_xorg-server libdrm xlib_libX11 xlib_libXvMC xproto_fontsproto xproto_glproto xproto_randrproto xproto_renderproto xproto_xextproto xproto_xf86driproto xproto_xproto
+
+OPENCHROME_AUTORECONF = YES
+OPENCHROME_CONF_OPT = --enable-shared --disable-static
+
+$(eval $(call AUTOTARGETS,openchrome))