summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-14 11:16:09 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-14 11:20:38 +0100
commit921f75e2607e7f3d16b7ba8ee62ed68a3632eeb7 (patch)
tree52d34a6933d342adc08bedb6d8f233736a90fa62 /fs
parentacd062778f940e91ae27643b1620e205ecd04816 (diff)
fs/jffs2: remove BR2_JFFS2_TARGET_SREC option
This kind of custom image conversion is better handled outside BR. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/jffs2/Config.in5
-rw-r--r--fs/jffs2/jffs2.mk10
2 files changed, 1 insertions, 14 deletions
diff --git a/fs/jffs2/Config.in b/fs/jffs2/Config.in
index edb1f4d94..5748fbb63 100644
--- a/fs/jffs2/Config.in
+++ b/fs/jffs2/Config.in
@@ -80,11 +80,6 @@ config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
Do not use cleanmarkers if using NAND flash or Dataflash where
the pagesize is not a power of 2
-config BR2_JFFS2_TARGET_SREC
- bool "RootFS in SREC file format"
- help
- The binary data will be encoded in Motorola's S-record format
-
config BR2_TARGET_ROOTFS_JFFS2_PAD
bool "Pad output"
diff --git a/fs/jffs2/jffs2.mk b/fs/jffs2/jffs2.mk
index fd5da0c1b..2a69849cd 100644
--- a/fs/jffs2/jffs2.mk
+++ b/fs/jffs2/jffs2.mk
@@ -46,12 +46,4 @@ define ROOTFS_JFFS2_CMD
endef
endif
-define JFFS2_GEN_SREC
- $(TARGET_CROSS)objcopy -I binary -O srec --adjust-vma 0xa1000000 $$@ $$@.srec
-endef
-
-ifeq ($(BR2_JFFS2_TARGET_SREC),y)
-ROOTFS_JFFS2_POST_GEN_HOOKS += JFFS2_GEN_SREC
-endif
-
-$(eval $(call ROOTFS_TARGET,jffs2)) \ No newline at end of file
+$(eval $(call ROOTFS_TARGET,jffs2))